设为首页 - 加入收藏
广告 1000x90
您的当前位置:必赢亚洲线路检测中心 > 教程 > 办公软件 > 正文

在dos的cmd模式下执行php 已加载的模块都不能使用

来源:未知 编辑:admin 时间:2019-03-01

  正在cmd下有试过其他php文献,只消是没用须加载模块的function都ok,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台有加载的都报错

  可选中1个或众个下面的闭头词,搜求联系材料。也可直接点“搜求材料”搜求全部题目。

  睁开通盘这个是由于php的没有被确切读取到,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台所爆发的模块没有加载的题目,旨趣是,你的cli形式的php载入是的是一个php.ini,而你的效劳器载入的是别的一个php.ini。或者是你呆板上的php的cli版本和效劳器利用的php的版本不相同等境况,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台都有恐怕导致这种境况。

  1. 同楼上,利用dl来加载模块,但是这种伎俩某些平台不扶助,且效益和同效劳器上利用php.ini加载的模块利用起来效益恐怕会不相同。

  2. 正在号召行履行php时,利用php --ini号召先行查看php加载的筑设文献的地点与效劳器上用phpinfo函数查看到的php加载的php.ini文献是否相同。必赢亚洲线路检测中心,383ww.net,bwin娱乐平台(LZ的这个纰谬众半是这种境况,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台后续伎俩是基于这个反省出文献不相同的)

  1. 很有恐怕你的呆板上安设了众个php版本,利用浏览器访候的时分用的php是5.2的,而正在号召行里利用的php版本是php 5.3的,云云就不难注明提示筑设文献一面派置已失效;

  正在号召行下php -v查看此刻号召行下php版本,写一个php剧本,挪用phpinfo函数,查看下浏览器下访候时php的周详处境新闻,席卷php版本,php的ini地点,php加载的模块等。

  若是反省到号召行下是php5.3,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台而浏览器用的是php5.2,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台题目可能通过编削PATH处境变量,把PHP5.2的文献夹加到PATH内部,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台必赢亚洲线路检测中心,383ww.net,bwin娱乐平台去掉PHP5.3的。

  若是反省到PHP的ini文献加载纰谬,浏览器加载的是apache 筑设中 通过 PHPIniDir 筑设的ini文献话,必赢亚洲线路检测中心,383ww.net,bwin娱乐平台把这个ini笼盖C:Windows下的即可。

相关推荐:

网友评论:

发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片

网站地图 | xml地图

Copyright © 2012-2019 必赢亚洲线路检测中心  版权所有

Top